Elementor <= 3.13.2 Authenticated(Contributor+) Arbitrary Post Type Creation via save_item

Creation of Emergent Resource
CVE CVE-2023-33922
CVSS 5.4 (Medium)
Publicly Published May 22, 2023
Last Updated May 30, 2023
Researcher Rafie Muhammad - Patchstack


The Elementor plugin for WordPress is vulnerable to the creation of emergent resources due to insufficient input validation in the template "save_item" function in versions up to, and including, 3.13.3. This allows authenticated attackers, with contributor-level permissions or above, to create templates with an arbitrary post type, potentially allowing the exploitation of other plugins that depend on custom post types.



1 affected software package

Software Type Plugin
Software Slug elementor (view on wordpress.org)
Patched? Yes
Remediation Update to version 3.13.3, or a newer patched version
Affected Version
  • < 3.13.3
Patched Version
  • 3.13.3

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.