Elementor <= 3.18.1 - Authenticated(Contributor+) Arbitrary File Upload to Remote Code Execution via Template Import

8.8
Unrestricted Upload of File with Dangerous Type
CVE CVE-2023-48777
CVSS 8.8 (High)
Publicly Published December 6, 2023
Last Updated December 8, 2023
Researcher Hong Quan

Description

The Elementor Website Builder – More than Just a Page Builder plugin for WordPress is vulnerable to Remote Code Execution via file upload in all versions up to and including 3.18.1 via the template import functionality. This makes it possible for authenticated attackers, with contributor-level access and above, to upload files and execute code on the server.

Wordfence blocked 7 attacks targeting this vulnerability in the past 24 hours.

References

Share

Vulnerability Details for Elementor Website Builder – More than Just a Page Builder

Software Type Plugin
Software Slug elementor (view on wordpress.org)
Patched? Yes
Remediation Update to version 3.18.2, or a newer patched version
Affected Version
  • <= 3.18.1
Patched Version
  • 3.18.2

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation