Elements Kit Lite/Pro <= 2.1.7 - Authenticated (Contributor+) Stored Cross-Site Scripting

5.4
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2021-24258
CVSS 5.4 (Medium)
Publicly Published April 13, 2021
Last Updated January 19, 2023
Researcher Ram - Wordfence

Description

The Elements Kit Lite and Elements Kit Pro WordPress Plugins before 2.2.0 have a number of widgets that are vulnerable to stored Cross-Site Scripting (XSS) by lower-privileged users such as contributors, all via a similar method.

Wordfence blocked 458 attacks targeting this vulnerability in the past 24 hours.

References

Share

Vulnerability Details for ElementsKit Elementor addons

Software Type Plugin
Software Slug elementskit-lite (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.2.0, or a newer patched version
Affected Version
  • <= 2.1.7
Patched Version
  • 2.2.0

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation