ElementsKit Lite <= 3.0.3 - Unauthenticated Sensitive Information Exposure

Improper Access Control
CVE CVE-2023-6582
CVSS 5.3 (Medium)
Publicly Published January 8, 2024
Last Updated January 22, 2024
Researcher Nex Team


The ElementsKit Elementor addons plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 3.0.3 via the ekit_widgetarea_content function. This makes it possible for unauthenticated attackers to obtain contents of posts in draft, private or pending review status that should not be visible to the general public. This applies to posts created with Elementor only.



Vulnerability Details for ElementsKit Elementor addons

Software Type Plugin
Software Slug elementskit-lite (view on wordpress.org)
Patched? Yes
Remediation Update to version 3.0.4, or a newer patched version
Affected Version
  • <= 3.0.3
Patched Version
  • 3.0.4

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.