Email Before Download <= 3.4 - SQL Injection

9.8
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')
CVSS 9.8 (Critical)
Publicly Published July 28, 2015
Last Updated December 28, 2022
Researcher Clément Notin

Description

The Email Before Download plugin for WordPress is vulnerable to SQL Injection in versions up to, and including, 3.4 due to insufficient escaping on several user-supplied parameters and lack of sufficient preparation on existing SQL queries. This makes it possible for unauthenticated attackers to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.

References

Share

1 affected software package

Software Type Plugin
Software Slug email-before-download (view on wordpress.org)
Patched? Yes
Remediation Update to version 3.4.1, or a newer patched version
Affected Version
  • <= 3.4
Patched Version
  • 3.4.1

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation