Email Log <= 2.4.8 - Unauthenticated Hook Injection

Improper Control of Generation of Code ('Code Injection')
CVE CVE-2024-0867
CVSS 8.1 (High)
Publicly Published May 23, 2024
Last Updated May 24, 2024
Researcher Sean Murphy


The Email Log plugin for WordPress is vulnerable to Unauthenticated Hook Injection in all versions up to, and including, 2.4.8 via the check_nonce function. This makes it possible for unauthenticated attackers to execute actions with hooks in WordPress under certain circumstances. The action the attacker wishes to execute needs to have a nonce check, and the nonce needs to be known to the attacker. Furthermore, the absence of a capability check is a requirement.



Vulnerability Details for Email Log

Software Type Plugin
Software Slug email-log (view on
Patched? Yes
Remediation Update to version 2.4.9, or a newer patched version
Affected Version
  • <= 2.4.8
Patched Version
  • 2.4.9

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.