Customer Email Verification for WooCommerce <= 2.7.4 - Email Verification and Authentication Bypass due to Insufficient Randomness

Use of Insufficiently Random Values
CVE CVE-2024-4185
CVSS 8.1 (High)
Publicly Published April 29, 2024
Last Updated April 30, 2024
Researcher István Márton - Wordfence


The Customer Email Verification for WooCommerce plugin for WordPress is vulnerable to Email Verification and Authentication Bypass in all versions up to, and including, 2.7.4 via the use of insufficiently random activation code. This makes it possible for unauthenticated attackers to bypass the email verification, and if both the "Login the user automatically after the account is verified" and "Verify account for current users" options are checked, then it potentially makes it possible for attackers to bypass authentication for other users.



Vulnerability Details for Customer Email Verification for WooCommerce

Software Type Plugin
Software Slug emails-verification-for-woocommerce (view on
Patched? Yes
Remediation Update to version 2.7.5, or a newer patched version
Affected Version
  • <= 2.7.4
Patched Version
  • 2.7.5

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.