EmbedPress <= 3.8.2 - Missing Authorization to Authenticated (Subscriber+) Plugin Settings Delete via admin_post_remove and remove_private_data

Missing Authorization
CVE CVE-2023-4282
CVSS 5.4 (Medium)
Publicly Published August 9, 2023
Last Updated August 10, 2023
Researcher István Márton - Wordfence


The EmbedPress plugin for WordPress is vulnerable to unauthorized loss of data due to a missing capability check on the 'admin_post_remove' and 'remove_private_data' functions in versions up to, and including, 3.8.2. This makes it possible for authenticated attackers with subscriber privileges or above, to delete plugin settings.



1 affected software package

Software Type Plugin
Software Slug embedpress (view on wordpress.org)
Patched? Yes
Remediation Update to version 3.8.3, or a newer patched version
Affected Version
  • <= 3.8.2
Patched Version
  • 3.8.3

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.