EmbedPress <= 3.9.8 - Missing Authorization via handle_calendly_data

5.3
Missing Authorization
CVE CVE-2024-31284
CVSS 5.3 (Medium)
Publicly Published April 5, 2024
Last Updated April 11, 2024
Researcher Majed Refaea

Description

The EmbedPress plugin for WordPress is vulnerable to unauthorized access due to a missing capability check on the handle_calendly_data() function in versions up to, and including, 3.9.8. This makes it possible for unauthenticated attackers to update calendly settings.

References

Share

Vulnerability Details for EmbedPress – Embed PDF, Google Docs, Vimeo, Wistia, Embed YouTube Videos, Audios, Maps & Embed Any Documents in Gutenberg & Elementor

Software Type Plugin
Software Slug embedpress (view on wordpress.org)
Patched? Yes
Remediation Update to version 3.9.9, or a newer patched version
Affected Version
  • <= 3.9.8
Patched Version
  • 3.9.9

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation