Emergency Password Reset <= 8.0 - Cross-Site Request Forgery

Cross-Site Request Forgery (CSRF)
CVE CVE-2024-35648
CVSS 4.3 (Medium)
Publicly Published June 3, 2024
Last Updated June 11, 2024
Researcher Pedro José Navas Pérez


The Emergency Password Reset plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 8.0. This is due to missing or incorrect nonce validation in the index.php file. This makes it possible for unauthenticated attackers to update the plugin's settings via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.



Vulnerability Details for Emergency Password Reset

Software Type Plugin
Software Slug emergency-password-reset (view on wordpress.org)
Patched? Yes
Remediation Update to version 9.0, or a newer patched version
Affected Version
  • <= 8.0
Patched Version
  • 9.0

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.