Enable Media Replace <= 3.6.3 - Authenticated (Administrator+) Path Traversal

Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')
CVE CVE-2022-2554
CVSS 6.8 (Medium)
Publicly Published September 14, 2022
Last Updated January 22, 2024
Researcher Raad Haddad


The Enable Media Replace plugin for WordPress is vulnerable to path traversal when renaming files in versions up to, and including, 3.6.3. This makes it possible for authenticated attackers, with administrator-level permissions and above, to move files on the affected site's server outside of the webroot.



Vulnerability Details for Enable Media Replace

Software Type Plugin
Software Slug enable-media-replace (view on wordpress.org)
Patched? Yes
Remediation Update to version 4.0.0, or a newer patched version
Affected Version
  • <= 3.6.3
Patched Version
  • 4.0.0

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.