All-in-one Google Analytics, Pixels and Product Feed Manager for WooCommerce <= 5.2.3 - Cross-Site Request Forgery

4.3
Cross-Site Request Forgery (CSRF)
CVE CVE-2022-46797
CVSS 4.3 (Medium)
Publicly Published February 6, 2023
Last Updated February 10, 2023
Researcher Muhammad Daffa

Description

The All-in-one Google Analytics, Pixels and Product Feed Manager for WooCommerce plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 5.2.3. This is due to missing or incorrect nonce validation on multiple functions like tvc_call_add_customer_feedback. This makes it possible for unauthenticated attackers to make a user with higher privileges perform unintended actions such as adding customer feedback, via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.

References

Share

Vulnerability Details for Conversios – Google Analytics 4 (GA4), Meta Pixel & more Via Google Tag Manager For WooCommerce

Software Type Plugin
Software Slug enhanced-e-commerce-for-woocommerce-store (view on wordpress.org)
Patched? Yes
Remediation Update to version 5.2.4, or a newer patched version
Affected Version
  • <= 5.2.3
Patched Version
  • 5.2.4

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation