CM Tooltip Glossary – Powerful Glossary Plugin <= 4.2.11 - Cross-Site Request Forgery

Cross-Site Request Forgery (CSRF)
CVE CVE-2024-4086
CVSS 4.3 (Medium)
Publicly Published April 24, 2024
Last Updated May 2, 2024
Researcher Benedictus Jovan (aillesiM)


The CM Tooltip Glossary – Powerful Glossary Plugin plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 4.2.11. This is due to missing or incorrect nonce validation when saving settings. This makes it possible for unauthenticated attackers to change the plugin's settings or reset them via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.



Vulnerability Details for CM Tooltip Glossary

Software Type Plugin
Software Slug enhanced-tooltipglossary (view on
Patched? Yes
Remediation Update to version 4.3.0, or a newer patched version
Affected Version
  • <= 4.2.11
Patched Version
  • 4.3.0

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.