Envo Extra <= 1.8.23 - Authenticated (Contributor+) Stored Cross-Site Scripting via Button Widget

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2024-5645
CVSS 6.4 (Medium)
Publicly Published June 6, 2024
Last Updated June 7, 2024
Researcher wesley (wcraft)


The Envo Extra plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘button_css_id’ parameter within the Button widget in all versions up to, and including, 1.8.23 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.



Vulnerability Details for Envo Extra

Software Type Plugin
Software Slug envo-extra (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.8.25, or a newer patched version
Affected Version
  • <= 1.8.23
Patched Version
  • 1.8.25

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.