WP Poll Maker <= 3.1 - Authenticated (Subscriber+) Arbitrary File Deletion

Missing Authorization
CVE CVE-2024-31240
CVSS 8.8 (High)
Publicly Published April 5, 2024
Last Updated April 10, 2024
Researcher beluga


The WP Poll Maker – Best WordPress Poll Plugin for Voting Contest plugin for WordPress is vulnerable to arbitrary file deletion due to a missing capability check on the it_epoll_theme_action_uninstall() function and insufficient file path validation in all versions up to, and including, 3.1. This makes it possible for authenticated attackers, with subscriber-level access and above, to delete arbitrary files that may make remote code execution possible.



Vulnerability Details for ePoll – Best WordPress Voting Plugin for Poll & Contest

Software Type Plugin
Software Slug epoll-wp-voting (view on wordpress.org)
Patched? Yes
Remediation Update to version 3.4, or a newer patched version
Affected Version
  • <= 3.1
Patched Version
  • 3.4

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.