WP ERP <=1.10.5 - Sensitive Data Exposure

Improper Authorization
CVSS 6.3 (Medium)
Publicly Published July 26, 2022
Last Updated January 22, 2024


The WP ERP Plugin for WordPress is vulnerable to Sensitive Data Exposure in versions up to, and including, 1.10.5 due to missing authorization checks in a number of functions, including 'generate_csv_url', which leaks a nonce used to import CSV files.



Vulnerability Details for WP ERP | Complete HR solution with recruitment & job listings | WooCommerce CRM & Accounting

Software Type Plugin
Software Slug erp (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.10.6, or a newer patched version
Affected Version
  • <= 1.10.5
Patched Version
  • 1.10.6

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.