Essential Addons for Elementor Pro <= 5.4.8 - Unauthenticated Server-Side Request Forgery

Server-Side Request Forgery (SSRF)
CVE CVE-2023-32245
CVSS 7.3 (High)
Publicly Published May 15, 2023
Last Updated May 19, 2023
Researcher Rafie Muhammad - Patchstack


The Essential Addons for Elementor Pro plugin for WordPress is vulnerable to Server-Side Request Forgery in versions up to, and including, 5.4.8. This can allow unauthenticated attackers to make web requests to arbitrary locations originating from the web application which can be used to query and modify information from internal services.



Vulnerability Details for Essential Addons for Elementor Pro

Software Type Plugin
Software Slug essential-addons-elementor
Patched? Yes
Remediation Update to version 5.4.9, or a newer patched version
Affected Version
  • <= 5.4.8
Patched Version
  • 5.4.9

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.