Essential Addons for Elementor <= 5.7.1 - Unauthenticated Arbitrary Password Reset to Privilege Escalation

Unverified Password Change
CVE CVE-2023-32243
CVSS 9.8 (Critical)
Publicly Published May 11, 2023
Last Updated January 22, 2024
Researcher Rafie Muhammad - Patchstack


The Essential Addons for Elementor plugin for WordPress is vulnerable to Unauthenticated Arbitrary Password Resets to Privilege Escalation in versions up to, and including, 5.7.1. This is due to a lack of validation of a password reset key in the reset_password function. This makes it possible for unauthenticated attackers to reset the password of any user on a vulnerable site, including an administrator, if they have the email or username of the targeted account.

Wordfence blocked 1,094 attacks targeting this vulnerability in the past 24 hours.



1 affected software package

Software Type Plugin
Software Slug essential-addons-for-elementor-lite (view on
Patched? Yes
Remediation Update to version 5.7.2, or a newer patched version
Affected Version
  • <= 5.7.1
Patched Version
  • 5.7.2

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.