Essential Addons For Elementor <=5.8.1 - Unauthenticated MailChimp API Key Disclosure

5.3
Information Exposure
CVE CVE-2023-3779
CVSS 5.3 (Medium)
Publicly Published July 19, 2023
Last Updated January 22, 2024
Researcher Ulyses Saicha

Description

The Essential Addons For Elementor plugin for WordPress is vulnerable to unauthenticated API key disclosure in versions up to, and including, 5.8.1 due to the plugin adding the API key to the source code of any page running the MailChimp block. This makes it possible for unauthenticated attackers to obtain a site's MailChimp API key. We recommend resetting any MailChimp API keys if running a vulnerable version of this plugin with the MailChimp block enabled as the API key may have been compromised. This only affects sites running the premium version of the plugin and that have the Mailchimp block enabled on a page.

References

Share

Vulnerability Details for Essential Addons for Elementor – Best Elementor Templates, Widgets, Kits & WooCommerce Builders

Software Type Plugin
Software Slug essential-addons-for-elementor-lite (view on wordpress.org)
Patched? Yes
Remediation Update to version 5.8.2, or a newer patched version
Affected Version
  • <= 5.8.1
Patched Version
  • 5.8.2

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation