Essential Blocks <= 4.0.6 - Missing Authorization via template_count

Missing Authorization
CVE CVE-2023-2086
CVSS 4.3 (Medium)
Publicly Published April 18, 2023
Last Updated June 9, 2023
Researcher Marco Wotschka


The Essential Blocks plugin for WordPress is vulnerable to unauthorized use of functionality due to a missing capability check on the template_count function in versions up to, and including, 4.0.6. This makes it possible for subscriber-level attackers to obtain plugin template information. While a nonce check is present, it is only executed when a nonce is provided. Not providing a nonce results in the nonce verification to be skipped. There is no capability check.



1 affected software package

Software Type Plugin
Software Slug essential-blocks (view on
Patched? Yes
Remediation Update to version 4.0.7, or a newer patched version
Affected Version
  • <= 4.0.6
Patched Version
  • 4.0.7

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.