Essential Blocks <= 4.4.2 - Unauthenticated Local File Inclusion

Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')
CVE CVE-2023-6623
CVSS 9.8 (Critical)
Publicly Published December 21, 2023
Last Updated February 6, 2024
Researcher Marc-Alexandre Montpas


The Essential Blocks – Page Builder Gutenberg Blocks, Patterns & Templates plugin for WordPress is vulnerable to Local File Inclusion in all versions up to, and including, 4.4.2 via the /wp-json/essential-blocks/v1/queries REST API endpoint. This makes it possible for unauthenticated attackers to include and execute arbitrary files on the server, allowing the execution of any PHP code in those files. This can be used to bypass access controls, obtain sensitive data, or achieve code execution in cases where images and other “safe” file types can be uploaded and included.



Vulnerability Details for Essential Blocks – Page Builder Gutenberg Blocks, Patterns & Templates

Software Type Plugin
Software Slug essential-blocks (view on
Patched? Yes
Remediation Update to version 4.4.3, or a newer patched version
Affected Version
  • <= 4.4.2
Patched Version
  • 4.4.3

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.