Essential Grid <= 3.0.18 - Missing Authorization

Missing Authorization
CVE CVE-2023-47771
CVSS 8.3 (High)
Publicly Published November 14, 2023
Last Updated January 22, 2024
Researcher Rafie Muhammad - Patchstack


The Essential Grid plugin for WordPress is vulnerable to unauthorized access of functionality due to a missing capability check on several functions in versions up to, and including, 3.0.18. This makes it possible for authenticated attackers, with subscriber-level access and above, to access those functions intended for higher privileged users. The exact consequences are not known.



1 affected software package

Software Type Plugin
Software Slug essential-grid (view on
Patched? Yes
Remediation Update to version 3.0.19, or a newer patched version
Affected Version
  • <= 3.0.18
Patched Version
  • 3.0.19

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.