EventPrime <= 3.3.4 - Missing Authorization to Booking Price Maniputlation

External Control of Assumed-Immutable Web Parameter
CVE CVE-2024-31275
CVSS 5.3 (Medium)
Publicly Published April 5, 2024
Last Updated April 11, 2024
Researcher Joshua Chan


The EventPrime plugin for WordPress is vulnerable to booking price manipulations due to insufficient validation and control of booking prices in versions up to, and including, 3.3.4. This makes it possible for unauthenticated attackers to make bookings with lower prices.



Vulnerability Details for EventPrime – Events Calendar, Bookings and Tickets

Software Type Plugin
Software Slug eventprime-event-calendar-management (view on wordpress.org)
Patched? Yes
Remediation Update to version 3.3.5, or a newer patched version
Affected Version
  • <= 3.3.4
Patched Version
  • 3.3.5

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.