EventPrime <= 3.3.9 - Improper Input Validation via save_event_booking

Improper Input Validation
CVE CVE-2024-24832
CVSS 5.3 (Medium)
Publicly Published February 2, 2024
Last Updated February 5, 2024
Researcher Abdi Pranata


The EventPrime plugin for WordPress is vulnerable to unauthorized modification of data due to improper input validation in the 'save_event_booking' function in versions up to, and including, 3.3.9. This makes it possible for unauthenticated attackers to modify the price and other attributes of purchased tickets.



1 affected software package

Software Type Plugin
Software Slug eventprime-event-calendar-management (view on wordpress.org)
Patched? Yes
Remediation Update to version 3.4.0, or a newer patched version
Affected Version
  • <= 3.3.9
Patched Version
  • 3.4.0

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.