EventPrime – Events Calendar, Bookings and Tickets <= 3.4.2 - Missing Authorization to Arbitrary Post Overwrite

Missing Authorization
CVE CVE-2024-1123
CVSS 6.5 (Medium)
Publicly Published March 8, 2024
Last Updated March 9, 2024
Researcher Lucio Sá


The EventPrime – Events Calendar, Bookings and Tickets plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the save_frontend_event_submission() function in all versions up to, and including, 3.4.2. This makes it possible for authenticated attackers, with subscriber-level access and above, to overwrite the title and content of arbitrary posts. This can also be exploited by unauthenticated attackers when the allow_submission_by_anonymous_user setting is enabled.



Vulnerability Details for EventPrime – Events Calendar, Bookings and Tickets

Software Type Plugin
Software Slug eventprime-event-calendar-management (view on wordpress.org)
Patched? Yes
Remediation Update to version 3.4.3, or a newer patched version
Affected Version
  • <= 3.4.2
Patched Version
  • 3.4.3

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.