Events Manager <= 5.9.5 - Authenticated Stored Cross-Site Scripting

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2019-16523
CVSS 6.4 (Medium)
Publicly Published October 16, 2019
Last Updated January 22, 2024
Researcher Tobias Fink


The events-manager plugin through 5.9.5 for WordPress (aka Events Manager) is susceptible to Stored XSS due to improper encoding and insertion of data provided to the attribute map_style of shortcodes (locations_map and events_map) provided by the plugin.



Vulnerability Details for Events Manager – Calendar, Bookings, Tickets, and more!

Software Type Plugin
Software Slug events-manager (view on
Patched? Yes
Remediation Update to version 5.9.6, or a newer patched version
Affected Version
  • <= 5.9.5
Patched Version
  • 5.9.6

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.