Everest Forms <= 2.0.7 - Unauthenticated Server-Side Request Forgery via font_url

Server-Side Request Forgery (SSRF)
CVE CVE-2024-1812
CVSS 7.2 (High)
Publicly Published March 15, 2024
Last Updated April 9, 2024
Researcher hir0ot


The Everest Forms plugin for WordPress is vulnerable to Server-Side Request Forgery in all versions up to, and including, 2.0.7 via the 'font_url' parameter. This makes it possible for unauthenticated attackers to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services.



Vulnerability Details for Everest Forms ā€“ Build Contact Forms, Surveys, Polls, Quizzes, Newsletter & Application Forms, and Many More with Ease!

Software Type Plugin
Software Slug everest-forms (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.0.8, or a newer patched version
Affected Version
  • <= 2.0.7
Patched Version
  • 2.0.8

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.