Fancy Product Designer <= 4.6.9 - Insufficient Authorization on Mulitple AJAX Actions

Improper Authorization
CVE CVE-2021-4335
CVSS 6.3 (Medium)
Publicly Published April 5, 2023
Last Updated April 5, 2023
Researcher Ramuel Gall - Wordfence


The Fancy Product Designer plugin for WordPress is vulnerable to unauthorized access to data and modification of plugin settings due to a missing capability check on multiple AJAX functions in versions up to, and including, 4.6.9. This makes it possible for authenticated attackers with subscriber-level permissions to modify plugin settings, including retrieving arbitrary order information or creating/updating/deleting products, orders, or other sensitive information not associated with their own account.



1 affected software package

Software Type Plugin
Software Slug fancy-product-designer
Patched? Yes
Remediation Update to version 4.7.0, or a newer patched version
Affected Version
  • <= 4.6.9
Patched Version
  • 4.7.0

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.