Fancy Product Designer <= 4.6.9 - Insufficient Authorization to Arbitrary Options Update via fpd_update_options

Improper Authorization
CVE CVE-2021-4334
CVSS 8.8 (High)
Publicly Published April 5, 2023
Last Updated January 22, 2024
Researcher Ram - Wordfence


The Fancy Product Designer plugin for WordPress is vulnerable to unauthorized modification of site options due to a missing capability check on the fpd_update_options function in versions up to, and including, 4.6.9. This makes it possible for authenticated attackers with subscriber-level permissions to modify site options, including setting the default role to administrator which can allow privilege escalation.



Vulnerability Details for Fancy Product Designer

Software Type Plugin
Software Slug fancy-product-designer
Patched? Yes
Remediation Update to version 4.7.0, or a newer patched version
Affected Version
  • <= 4.6.9
Patched Version
  • 4.7.0

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.