Fancy Product Designer <= 4.7.5 - Cross-Site Request Forgery to Arbitrary File Upload

Cross-Site Request Forgery (CSRF)
CVE CVE-2021-4096
CVSS 8.8 (High)
Publicly Published April 14, 2022
Last Updated January 22, 2024
Researcher Lin Yu


The Fancy Product Designer plugin for WordPress is vulnerable to Cross-Site Request Forgery via the FPD_Admin_Import class that makes it possible for attackers to upload malicious files that could be used to gain webshell access to a server in versions up to, and including, 4.7.5.



Vulnerability Details for Fancy Product Designer

Software Type Plugin
Software Slug fancy-product-designer
Patched? Yes
Remediation Update to version 4.7.6, or a newer patched version
Affected Version
  • <= 4.7.5
Patched Version
  • 4.7.6

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.