Fastly <= 1.2.25 - Missing Authorization via AJAX actions

Missing Authorization
CVE CVE-2024-34768
CVSS 4.3 (Medium)
Publicly Published May 17, 2024
Last Updated May 20, 2024
Researcher Joshua Chan


The Fastly plugin for WordPress is vulnerable to unauthorized access to functionality due to a missing capability check on the plugin's AJAX actions in versions up to, and including, 1.2.25. This makes it possible for authenticated attackers, with subscriber-level access and above, to invoke functions intended for administrators leading to cache modification.



Vulnerability Details for Fastly

Software Type Plugin
Software Slug fastly (view on
Patched? Yes
Remediation Update to version 1.2.26, or a newer patched version
Affected Version
  • <= 1.2.25
Patched Version
  • 1.2.26

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.