Featured Post Creative <= 1.2.7 - Missing Authorization via wpfp_update_featured_post

Missing Authorization
CVE CVE-2023-30488
CVSS 5.3 (Medium)
Publicly Published April 13, 2023
Last Updated April 17, 2023
Researcher Cat


The Featured Post Creative plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the wpfp_update_featured_post function called via a nopriv AJAX action in versions up to, and including, 1.2.7. This makes it possible for unauthenticated attackers to change what post is featured.



1 affected software package

Software Type Plugin
Software Slug featured-post-creative (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.2.8, or a newer patched version
Affected Version
  • <= 1.2.7
Patched Version
  • 1.2.8

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.