File Manager Advanced Shortcode WordPress <= 2.3.2 - Unauthenticated Arbitrary File Upload to Remote Code Execution via Shortcode

Improper Control of Generation of Code ('Code Injection')
CVE CVE-2023-2068
CVSS 9.8 (Critical)
Publicly Published May 31, 2023
Last Updated June 19, 2023
Researcher Mateus Machado Tesser


The File Manager Advanced Shortcode WordPress plugin for WordPress is vulnerable to remote code execution in versions up to, and including, 2.3.2. This is due to the plugin allowing users to upload PHP files when the shortcode has been added to a page/post. This makes it possible for unauthenticated users to potentially upload malicious PHP files if the shortcode is used on the front-end of the site, and makes it possible for authenticated users with access to a post editor to add the shortcode to a page or post and subsequently upload a malicious file.



1 affected software package

Software Type Plugin
Software Slug file-manager-advanced-shortcode
Patched? Yes
Remediation Update to version 2.4, or a newer patched version
Affected Version
  • <= 2.3.2
Patched Version
  • 2.4

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.