Advanced File Manager <= 5.1 - Authenticated(Administrator+) Arbitrary File and Folder Access

Improper Access Control
CVE CVE-2023-3814
CVSS 6.6 (Medium)
Publicly Published August 14, 2023
Last Updated September 8, 2023
Researcher Dmitrii Ignatyev - CleanTalk


The Advanced File Managerplugin for WordPress is vulnerable to improper access control in versions up to, and including, 5.1. This makes it possible for authenticated attackers, with administrator-level permissions and above, to access the filesystem on multisite installations. This only affects multi-site installations.



1 affected software package

Software Type Plugin
Software Slug file-manager-advanced (view on
Patched? Yes
Remediation Update to version 5.1.1, or a newer patched version
Affected Version
  • <= 5.1
Patched Version
  • 5.1.1

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.