Floating Action Button <= <=1.2.1 - Cross-Site Request Forgery to Settings Modification

Cross-Site Request Forgery (CSRF)
CVE CVE-2023-31088
CVSS 4.3 (Medium)
Publicly Published May 31, 2023
Last Updated July 31, 2023
Researcher Yuki Haruma


The Floating Action Button plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, <=1.2.1. This is due to missing or incorrect nonce validation on the 'wp_ajax_fz_fab_settings_save' AJAX action. This makes it possible for unauthenticated attackers to modify plugin settings via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.



1 affected software package

Software Type Plugin
Software Slug floating-action-button (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.2.2, or a newer patched version
Affected Version
  • <= 1.2.1
Patched Version
  • 1.2.2

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.