FluentSMTP <= 2.0.0 - Authenticated (Admin+) Stored Cross-Site Scripting

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2021-24528
CVSS 5.5 (Medium)
Publicly Published July 29, 2021
Last Updated December 5, 2022
Researcher YoshiKen


The FluentSMTP WordPress plugin before 2.0.1 does not sanitize parameters before storing the settings in the database, nor does the plugin escape the values before outputting them when viewing the SMTP settings set by this plugin, leading to a stored cross site scripting (XSS) vulnerability. Only users with roles capable of managing plugins can modify the plugin's settings.



1 affected software package

Software Type Plugin
Software Slug fluent-smtp (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.0.1, or a newer patched version
Affected Version
  • < 2.0.1
Patched Version
  • 2.0.1

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.