FluentSMTP <= 2.2.2 - Authenticated (Author+) Stored Cross-Site Scripting via Email Logs

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2023-0219
CVSS 3.8 (Low)
Publicly Published March 3, 2023
Last Updated March 8, 2023
Researcher Vaibhav Rajput


The FluentSMTP plugin for WordPress is vulnerable to Stored Cross-Site Scripting via sending mail (thus adding the payload into the logs of sent emails) in versions up to 2.2.3 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.



Vulnerability Details for FluentSMTP – WP SMTP Plugin with Amazon SES, SendGrid, MailGun, Postmark, Google and Any SMTP Provider

Software Type Plugin
Software Slug fluent-smtp (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.2.3, or a newer patched version
Affected Version
  • <= 2.2.2
Patched Version
  • 2.2.3

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.