Fluent Forms <= 5.1.9 - Authenticated (Contributor+) Stored Cross-Site Scripting

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2023-6957
CVSS 4.9 (Medium)
Publicly Published March 5, 2024
Last Updated March 13, 2024
Researcher drop


The Fluent Forms plugin for WordPress by Fluent Forms plugin for WordPress is vulnerable to Stored Cross-Site Scripting in all versions up to, and including, 5.1.9 due to insufficient input sanitization and output escaping. This makes it possible for attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The exploitation level depends on who is granted the right to create forms by an administrator. This level can be as low as contributor, but by default is admin.



Vulnerability Details for Contact Form Plugin by Fluent Forms for Quiz, Survey, and Drag & Drop WP Form Builder

Software Type Plugin
Software Slug fluentform (view on wordpress.org)
Patched? Yes
Remediation Update to version 5.1.10, or a newer patched version
Affected Version
  • <= 5.1.9
Patched Version
  • 5.1.10

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.