FluentForm <= 4.3.25 - Authenticated (Administrator+) SQL Injection

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')
CVE CVE-2023-24410
CVSS 7.2 (High)
Publicly Published July 12, 2023
Last Updated January 22, 2024
Researcher Ravi Dharmawan


The FluentForm plugin for WordPress is vulnerable to SQL Injection in versions up to, and including, 4.3.25 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with administrator-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.



Vulnerability Details for Contact Form Plugin by Fluent Forms for Quiz, Survey, and Drag & Drop WP Form Builder

Software Type Plugin
Software Slug fluentform (view on wordpress.org)
Patched? Yes
Remediation Update to version 5.0.0, or a newer patched version
Affected Version
  • <= 4.3.25
Patched Version
  • 5.0.0

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.