FluentForms <= 4.3.24 - Authenticated(Contributor+) Stored Cross-Site Scripting

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2023-0546
CVSS 6.4 (Medium)
Publicly Published March 20, 2023
Last Updated March 22, 2023
Researcher Vaibhav Rajput


The FluentForms plugin for WrodPress is vulnerable to stored Cross-Site Scripting via custom form fields in versions up to, and including, 4.3.24. This makes it possible for authenticated attackers, with contributor-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.



1 affected software package

Software Type Plugin
Software Slug fluentform (view on wordpress.org)
Patched? Yes
Remediation Update to version 4.3.25, or a newer patched version
Affected Version
  • <= 4.3.24
Patched Version
  • 4.3.25

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.