FlyingPress <= 3.9.6 - Missing Authorization

Missing Authorization
CVE CVE-2022-4948
CVSS 4.3 (Medium)
Publicly Published November 28, 2022
Last Updated June 7, 2023
Researcher Jerome Bruandet - NinTechNet


The FlyingPress plugin for WordPress is vulnerable to authorization bypass due to a missing capability check on its AJAX actions in versions up to, and including, 3.9.6. This makes it possible for authenticated attackers, with subscriber-level permissions and above, to interact with the plugin in ways administrators are intended to. One action (save_config) allows for the configuration of an external CDN. This could be used to include malicious javascript from a source controlled by the attacker.



1 affected software package

Software Type Plugin
Software Slug flying-press
Patched? Yes
Remediation Update to version 3.9.7, or a newer patched version
Affected Version
  • <= 3.9.6
Patched Version
  • 3.9.7

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.