Forget About Shortcode Buttons <= 2.1.2 - Missing Authorization via fasc_buttons

Missing Authorization
CVE CVE-2023-32579
CVSS 4.3 (Medium)
Publicly Published May 11, 2023
Last Updated May 15, 2023
Researcher Lana Codes


The Forget About Shortcode Buttons plugin for WordPress is vulnerable to unauthorized plugin settings update due to a missing capability check on the fasc_buttons function in versions up to, and including, 2.1.2. This makes it possible for authenticated attackers, with subscriber-level access or higher, to update the plugin's settings.



1 affected software package

Software Type Plugin
Software Slug forget-about-shortcode-buttons (view on
Patched? Yes
Remediation Update to version 2.1.3, or a newer patched version
Affected Version
  • <= 2.1.2
Patched Version
  • 2.1.3

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.