Formidable Forms <= 5.5.4 - Authenticated (Admin+) Server-Side Request Forgery

Server-Side Request Forgery (SSRF)
CVSS 4.7 (Medium)
Publicly Published December 16, 2022
Last Updated February 1, 2023


The Formidable Form Builder plugin for WordPress is vulnerable to Server-Side Request Forgery in versions up to, and including, 5.5.4 due to insufficient URL restrictions on the 'plugin' parameter passed to the the install_addon function. This makes it possible for authenticated users, with administrative privileges, to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services.



1 affected software package

Software Type Plugin
Software Slug formidable (view on
Patched? Yes
Remediation Update to version 5.5.5, or a newer patched version
Affected Version
  • <= 5.5.4
Patched Version
  • 5.5.5

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.