Formidable Forms <= 6.7 - HTML Injection

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2023-6830
CVSS 6.5 (Medium)
Publicly Published January 8, 2024
Last Updated February 8, 2024
Researcher drop


The Formidable Forms plugin for WordPress is vulnerable to HTML injection in versions up to, and including, 6.7. This vulnerability allows unauthenticated users to inject arbitrary HTML code into form fields. When the form data is viewed by an administrator in the Entries View Page, the injected HTML code is rendered, potentially leading to admin area defacement or redirection to malicious websites. CVE-2024-23522 appears to be a duplicate of this issue.



Vulnerability Details for Formidable Forms – Contact Form Plugin, Survey, Quiz, Payment, Calculator Form & Custom Form Builder

Software Type Plugin
Software Slug formidable (view on
Patched? Yes
Remediation Update to version 6.7.1, or a newer patched version
Affected Version
  • <= 6.7
Patched Version
  • 6.7.1

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.