Friends <= 2.8.5 - Authenticated (Admin+) Blind Server-Side Request Forgery

Server-Side Request Forgery (SSRF)
CVE CVE-2024-1978
CVSS 5.5 (Medium)
Publicly Published February 28, 2024
Last Updated February 29, 2024
Researcher Francisco Gutierrez - Appgate Threat Advisory Services Team


The Friends plugin for WordPress is vulnerable to Server-Side Request Forgery in all versions up to, and including, 2.8.5 via the discover_available_feeds function. This makes it possible for authenticated attackers, with administrator-level access and above, to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services.



Vulnerability Details for Friends

Software Type Plugin
Software Slug friends (view on
Patched? Yes
Remediation Update to version 2.8.6, or a newer patched version
Affected Version
  • <= 2.8.5
Patched Version
  • 2.8.6

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.