Front End Users <= 3.2.24 - Missing Authorization to Unauthenticated Registered User Deletion

Missing Authorization
CVSS 6.5 (Medium)
Publicly Published April 7, 2023
Last Updated April 7, 2023


The Front End Users plugin for WordPress is vulnerable to unauthorized modification and loss of data due to a missing capability check on several functions such as Mass_Delete_EWD_FEUP_Users, Delete_All_EWD_FEUP_Users, and Mass_Delete_EWD_FEUP_Fields in versions up to, and including, 3.2.24. This makes it possible for unauthenticated users to perform restricted actions such as deleting users that have registered through the plugin configuration.



1 affected software package

Software Type Plugin
Software Slug front-end-only-users (view on
Patched? Yes
Remediation Update to version 3.2.25, or a newer patched version
Affected Version
  • <= 3.2.24
Patched Version
  • 3.2.25

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.