Fusion Builder <= 3.6.1 & Avada <= 7.6.1 - Unauthenticated Server-Side Request Forgery

Server-Side Request Forgery (SSRF)
CVE CVE-2022-1386
CVSS 8.3 (High)
Publicly Published April 19, 2022
Last Updated December 5, 2022
Researcher Calum Elrick


The Fusion Builder plugin for WordPress, an Avada theme core plugin, is vulnerable to Server-Side Request Forgery in versions up to 3.6.2 along with the Avada theme in versions up to 7.6.2. This is due to insufficient validation in one of its form parameters. This makes it possible for unauthenticated attackers to interact with internal network hosts via specially crafted requests and can lead to sensitive information disclosure on certain configurations such as AWS.



Vulnerability Details for Fusion Builder

Software Type Plugin
Software Slug fusion-builder
Patched? Yes
Remediation Update to version 3.6.2, or a newer patched version
Affected Version
  • < 3.6.2
Patched Version
  • 3.6.2

1 other affected software package

Software Type Theme
Software Slug Avada
Patched? Yes
Remediation Update to version 7.6.2, or a newer patched version
Affected Version
  • < 7.6.2
Patched Version
  • 7.6.2

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.