Photo Gallery by Ays <= 5.1.6 - Reflected Cross-Site Scripting

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2023-2568
CVSS 6.1 (Medium)
Publicly Published May 16, 2023
Last Updated January 22, 2024
Researcher Erwan LR - WPScan


The Photo Gallery by Ays plugin for WordPress is vulnerable to Reflected Cross-Site Scripting in versions up to, and including, 5.1.6 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.



Vulnerability Details for Photo Gallery by Ays – Responsive Image Gallery

Software Type Plugin
Software Slug gallery-photo-gallery (view on
Patched? Yes
Remediation Update to version 5.1.7, or a newer patched version
Affected Version
  • <= 5.1.6
Patched Version
  • 5.1.7

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.