GamiPress <= 2.5.6 - Missing Authorization to User Points Updates

Missing Authorization
CVE CVE-2023-25715
CVSS 4.3 (Medium)
Publicly Published February 13, 2023
Last Updated February 16, 2023
Researcher Dave Jong - Patchstack


The GamiPress plugin for WordPress is vulnerable to unauthorized modification of user data due to a missing capability check on the gamipress_ajax_profile_update_user_points function in versions up to, and including, 2.5.6. This makes it possible for authenticated attackers with subscriber-level access or higher to manipulate rewards points of other users.



1 affected software package

Software Type Plugin
Software Slug gamipress (view on
Patched? Yes
Remediation Update to version 2.5.7, or a newer patched version
Affected Version
  • <= 2.5.6
Patched Version
  • 2.5.7

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.