GenerateBlocks <= 1.8.2 - Sensitive Information Exposure

Incorrect Authorization
CVE CVE-2024-1452
CVSS 4.3 (Medium)
Publicly Published March 1, 2024
Last Updated March 13, 2024
Researcher Webbernaut


The GenerateBlocks plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 1.8.2 via Query Loop. This makes it possible for authenticated attackers, with contributor access and above, to see contents of posts and pages in draft or private status as well as those with scheduled publication dates.



Vulnerability Details for GenerateBlocks

Software Type Plugin
Software Slug generateblocks (view on
Patched? Yes
Remediation Update to version 1.8.3, or a newer patched version
Affected Version
  • <= 1.8.2
Patched Version
  • 1.8.3

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.